Loading...
 
Features / Usability

Features / Usability


Error in Database (poll)

posts: 8355 Israel

Hi,

I have almost finished my customization and for my first poll i got an error.

An error occured in a database query!
Context:
File /tikiwiki/tiki-poll_results.php
Url /tikiwiki/tiki-poll_results.php?pollId=1
Query:
select `optionId` from `tiki_user_votings` where `user` = ? and `id` = ?
Values:
0 admin
1 poll1


Ho ???


Yoni

posts: 2881 United Kingdom

Hiya

If your using 1.9 RC2 the .sql file is broken for poll results table.

You can grab the latest from CVS and create the table.

Damian

posts: 8355 Israel

Hi Damian,

Nope, i use 1.9rc3.

I have customize styles and main menu.
I have edit header.pl (external editor) to set my color.


Nothing more



posts: 2881 United Kingdom

RC3 isnt a release yet its the latest development code, so what matters is the date that the database was created or upgraded to/from.

Damian


posts: 1092

Trying to see if I can find something..
I don't have problem on the last 1.9 (I suppose nothing change on this since rc3). I am sure I am not testing the n-th possibility in tiki
So when does this happen?
Viewing polls, voting?

posts: 8355 Israel

Hi Sylvie

So after Damian message, i'm not sure what version i got.

But it is CVS installed the 28/08/04 (using >> use cvs -z5 co -r BRANCH-1-9 tikiwiki for the future 1.9) by my hoster.

I can set the poll, diplay it, etc...

As i vote (i just retest it with another poll) when casting my vote it happen:

Error


An error occured in a database query!

Context:
File /tikiwiki/tiki-poll_results.php
Url /tikiwiki/tiki-poll_results.php?pollId=1
Query:
select `optionId` from `tiki_user_votings` where `user` = ? and `id` = ?
Values:
0 admin
1 poll1

I have set the polls to be shown under admin only to avoid everyone getting to it. You want me to set it for anonymous to see it ?


Yoni

posts: 2881 United Kingdom

You need to recreate the database table from the installation routine to get the missing or bad table.

You can also just create the missing tiki-poll_results manually through mysql command.

Damian

posts: 8355 Israel

Ok Damian,

I have open others tiki (1.83 and 1.8) tables from others site and i can't find something that look like "tiki-poll_results".


Is it possible for you to put here the exact query that should be writed into PhpMyadmin to create the table (or at least point where i can have spec).


If you tell me that it solved with the CVS upgrade (1.9 release) don't bother i will do it soon.


Yoni