Loading...
 
Features / Usability

Features / Usability


Blank page when editiing wiki pages

posts: 16

I've got a bit of an odd problem with one of my tikiwiki installs
I'm very certain the problem is with my setup but haven't a clue where.

I'm running 1.9rc3, though the problem has been around since 1.8, everything seems to be ok except my ability to edit wiki pages,
I have managed to edit a few pages previously but if I try to edit them or create a new page I just get a blank page returned, not even a <html> tag just nothing at all. If I don't have permission to edit the page that returns the correct error message.

It's RedHat linux advanced server 3
mysql 4.0.20
PHP 5.0.0
Apache 2.0.46

anyone else come across tis, or got any ideas on how to debug/fix it?

annoyingly it's the only thing that isn't working.

posts: 2881 United Kingdom

Hi,

Two things. PHP5 and probably PHP memory_limit.

Goto PHP 4.3.8/9 and a memory limit of 16 or 32Mb and i bet it will work biggrin

Damian

posts: 16

Already done the memory limit thing.
So I guess try a different version of PHP.

posts: 16

Hmm, changing php doesn't seem to have fixed it.

now on version: PHP Version 4.3.8
memory_limit = 32M

still get the same thing, no errors in the apache error log.

and no problems with any of it working except editing the wiki pages.

posts: 16

Having blown away the old install and rebuilt just in case, during the rebuild I found the rpoblem. It was down to a plugin I'd added to the
lib/wiki-plugins/
directory. When I added that back things broke when I removed it they worked again. So now I just have to fix the problem plugin.

But I do find it a little odd that a plugin that isn't even being used can break things so much. Might be worth a warning note in the plugins docs perhaps?


posts: 953

Something similar happened to me last week, the first time I browsed a Tiki installation (1.8.4) with MS Internet Explorer (5.5, on Win NT 4).

With Mozilla (on windows) I have never had that trouble.
In case it helps...

posts: 16

Sadly I usually use firefox , but havingjust tried with IE get the same problem.

Have even tried changing theme/stylesheet just in case that was the problem.


posts: 1

Has anyone found a solution to this "Blank page" problem? It happened to me these days. Increasing memory limit didn't work.

Any suggestion will be appreciated. Thanks.

> I've got a bit of an odd problem with one of my tikiwiki installs
> I'm very certain the problem is with my setup but haven't a clue where.
>
> I'm running 1.9rc3, though the problem has been around since 1.8, everything seems to be ok except my ability to edit wiki pages,
> I have managed to edit a few pages previously but if I try to edit them or create a new page I just get a blank page returned, not even a tag just nothing at all. If I don't have permission to edit the page that returns the correct error message.
>
> It's RedHat linux advanced server 3
> mysql 4.0.20
> PHP 5.0.0
> Apache 2.0.46
>
> anyone else come across tis, or got any ideas on how to debug/fix it?
>
> annoyingly it's the only thing that isn't working.