Loading...
 
Features / Usability

Features / Usability


Problems posting to blogs via xmlrpc

I'm having problems posting to blogs via XMLRPC API. The XMLRPC client returns a message that posts succeed, but data does not get posted.

Has this ever happened to anyone else here? How did you test?

I really don't feel like digging through the XMLRPC API code if I don't have to.

I have read the Tiki documentation on XMLRPC, which is better than most tiki documentation, but still of no specific help. The XMLRPC feature is enabled, My RPC Host is set to my_domain/xmlrpc.php in the XMLRPC client, my Blog ID and URL are correct (I can view the blog from the client, username and password have been verified as correct).

FWIW, I am using "Frequency" as my client. The "Get List" fucntinality also returns nothing (it is supposed to return a list of blogs on my host to which I can post).

Any help appreaciated.

Thanks,

wb

Thanks for the reply, Sylvie, but I don't think the OCmmunicatiosn Center has anything to do with it.

The reason I say this is because I have since gotten XMLRPC blgo posting to work in my dev environment - however, I can't seem to get it to work in production.

I have done painful comparisons of the code, along with comparison of includes, etc., and all seems to be alike except that my production environment is https.

Anyone know of any reasons why XML-RPC would not work via https. I personally don't think theres a problem with https, but maybe someone has encountered this before and can say "oh, yeah, ..."


Hi there,
With 1.9.0 it worked for me (and many other people in our site).
Using BloGtk (for GNU/Linux), or wBloggar for M$ Windows.
Posting worked ok, except that on BloGtk and other soft. on GNU/Linux didn't add the title of the post manually (it did, if we added manually between html tags for title and /title.

For wBloggar, titles went ok, but utf-8 is not fully supported by wBloggar yet.

Posting worked on them, editing them or other features via xmlrpc never worked for me.

OOps, I tried this morning to post through BloGtk, and I could as always to a 1.8.6 tiki site, but I couldn't to the 1.9.1 site, with the same account details with which I could when it was a 1.8.x version.
It looks like xmlrpc functioanlity is lost with 1.9.x...

Thanks xavid.

I may not have mentioned that I am using Ver. 1.9

Also, I have tested on a server via HTTP and it works just fine, but doesn't work via HTTPS.

I have downloaded some testing files which were packaged with the new version of xmlrpc*.inc (revised this past summer for security fixes), but have not yet had the chance to test.

wb


Bump

I have a fresh install of tikiwiki-1.8.6 and I get the following when I try to connect to /tiki/xmlrpc.php or the communications center:

-

-

-

-

-

faultCode
-

105


-

faultString
-

XML error: Invalid document end at line 1







What does that mean? How do I fix it? I found this by tryin wBloggar and it wouldn't connect. When I call the two scripts by hand I get the same message above.

Any ideas?

> I have a fresh install of tikiwiki-1.8.6
Betteer to use 1.9.2 for a fresh install

> > I have a fresh install of tikiwiki-1.8.6
> Betteer to use 1.9.2 for a fresh install

Ok I went through the hassle of upgrading to 1.9.2 and I get the exact same error from wBloggar....I get the following when calling it directly:

XML Parsing Error: syntax error
Location: http://msa04/tiki/xmlrpc.php
Line Number 1, Column 1:NULL
^

Any ideas?

Catalan Countries

> > I have a fresh install of tikiwiki-1.8.6
> Betteer to use 1.9.2 for a fresh install

Using bloGTk on Linux didn't work me either, nowadays, and it used to with 1.8.x.

Tried also with 1.10 cvs, but unsuccessfully (tried on 2 different servers with same unsuccess). xmlrpc Buggy still?


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.