Loading...
 
Architecture / Installation

Architecture / Installation


Cannot redeclare class Zend_Filter_Interface in /usr/local/lib/php/Zend/Filter/Interface.php

posts: 1

Attempting to install tikiwiki 3.0 I am faced with the following error message Cannot redeclare class Zend_Filter_Interface in /usr/local/lib/php/Zend/Filter/Interface.php on line 30.

I am installing onto a shared environment and 2.4 worked so I was wondering if anyone else has come across the same problem.

Thanks in advance

Mark

posts: 2 United States



Mark,
I have the same problem!

I tried to upgrade from v2.4 to v3.1 using cpanel and got the same error:
http://www.messofish.com/tikiwiki/tiki-index.php

Then I tried to do a brand new installation of v3.1 on another website using cpanel and got the same error.

Since I don't have admin access on the web servers, I cannot access line 30 of the Interface.php file.

I was able to install TikiWiki v3.1 on my Windows Vista laptop as well as a Linux Ubuntu 8.04 desktop and the application works fine on both machines.

This leads me to believe that it may be a problem with how cpanel installs/upgrades TikiWIki?


posts: 1811 Catalan Countries

Dear both: Welcome to Tikiwiki community first of all!
And after that, could you please add a bug report for this issue?:
http://dev.tikiwiki.org

Thanks in advanced


posts: 2 United States

xavi,
Thanks for the welcome!
I submitted a bug tonight, itemid=2641.


posts: 1

Just change line 3 in lib/core/lib/DeclFilter.php from
require_once 'lib/core/lib/Zend/Filter/Interface.php';
to
require_once 'Zend/Filter/Interface.php';



posts: 18 Australia

That fixed an install problem for me.
Installing on a local server using XAMPP.
Following the INSTALL file directions in the TikiWiki 3.1 package gives you that error.
The INSTALL file needs to be updated to reflect this "bug" for XAMPP users using Vista.
I have no idea how that is done so I will leave it up to someone to fix.