Loading...
 
Features / Usability

Features / Usability


I don't even have "tiki_p_plugin_approve"

My upgrade from 2.2->3.2 is still stumbling. Got a module on my front page, except it needs to be authorised. I checked around and it isn't listed under admin->plugins and editing->plugins. So I can't enable it there. I looked some more and got found I neet to visit:

tiki-plugins.php

Which tells me:

You do not have permission to use this feature: tiki_p_plugin_approve

Fine I say and go back to admin (even though I was logged in as admin at the time so should have all permissions) and look at the permissions for the admin group. No sign of "tiki_p_plugin_approve" in the list at all. It doesn't exist in my setup. So what next?

FYI my setup - I uploaded the tw 3.2 files into a dev location, created an empty db + user, imported and existing db into the fresh one figuring on carrying across as much of my setup as I could. Then I ran the installer choosing the upgrade/use existing connection path.

Canada

hmmmm

you need tiki_p_plugin_approve

looks like something didn't work on upgrade. You could easily manually add this perm in the DB. But since we don't know if it's the only thing that went wrong...

Can you try a clean install and see if that has the perm? (Just to rule out any weirdness on that side)

Related:
http://profiles.tikiwiki.org/Debug_Mode_Enabled

Thanks!


Germany

Maybe.
Anyway, a fresh/clean installation offers these three plugin permissions:
tiki_p_plugin_viewdetail
tiki_p_plugin_preview
tiki_p_plugin_approve

so imho the problem of izombieyou seems related to the upgrade.

Btw: Just edited the bug report to point another aspect of the bug.

cu goj


Okay so on a fresh install yes indeed I do have the needed permissions available to me so it is an issue with an upgrade install somewhere along the lines. In addition if I attempt to edit a page with a module in it when I attempt to save I do indeed get the issue I was pointed at:

http://dev.tikiwiki.org/wish2777

and that is true of both installs.

So I've got at least a couple of issues that I'm aware of and thinking about issues I've not yet discovered makes me a very sad boy.

I had kind of assumed a nice new major release version might be pretty robust, my whole reason for wanting the upgrade was to hopefully be able to get intertiki working but here I am not even able to successfully do a simple bare bones install, never mind importing the content already live on my sites: http://talisman-studios.com/wiki/tiki-index.php and http://www.suzerain.info/tiki-index.php.

Does anyone know if these issues are being worked on and likely to be resolved in a future release that hopefully isn't too far away? I'm a one man show and I was rather hoping the upgrade process was mostly going to be a case of making sure everything still worked, tweaking a few bits of configuration and reskinning, not chasing down errors and trying to figure out how to get around them and worrying about what that is going to mean for future upgrades.


also it wasn't until I started this upgrade I realised there had been a 2.3 and a 2.4, would I be better off upgrading from 2.2 incrementally through 2.3 and 2.4 before upgrading to 3.2 or is such not strictly necessary?
Canada

Upgrading from 2.2 to 3.2 is fine. You can even upgrade from 1.9.x to 3.2


But there is a bug in 3.2

It's being looked into. I think there will be a 3.2.1

well that is good to know and my thanks for the info on the bug. For the most part tiki wiki has been really good to me so I hope it gets sorted out nicely.

Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.