Loading...
 
Features / Usability

Features / Usability


Since upgrading to v14 I cannot get the WYSIWIG editor to show

USA

I have the default editor in the wiki set to the wiki editor but have the option for selecting the wysiwyg editor but since upgrading that seems to be broken. The page redraws (The editor portion) but the editor window is blank. I enabled logging and see that it looks like the CKEDITOR variable or object in the php code is missing or not defined. Is there something else I need to enable or load to get the CKEDITOR to be defined? This is running in a window and not fullscreen and I think the option for replacing the editor (I think something like that) is enabled because I can see the code that replaces the wiki editor window with the wysiwyg editor is part that is erroring:

Here is the errors and the code that is complaining:

TypeError: undefined is not an object (evaluating 'window.CKEDITOR.config')
ReferenceError: Can't find variable: CKEDITOR

CKEDITOR.replace( "editwiki",{
toolbar: ["Bold","Italic","Underline","Strike","-","TextColor","-","tikiimage","tikilink","externallink","Unlink","-","Undo","Redo","-","Find","Replace","-","RemoveFormat","SpecialChar","-","tikihelp","tikiswitch","autosave","admintoolbar"],"/",%22Format%22,%22Cut%22,%22Copy%22,%22Paste%22,%22-%22,%22JustifyLeft%22,%22JustifyCenter%22,%22-%22,%22BulletedList%22,%22NumberedList%22,%22-%22,%22PageBreak%22,%22HorizontalRule%22,%22-%22,%22tikitable%22,%22-%22,%22Source%22,%22ShowBlocks%22,%22screencapture%22,%22-%22,%22Maximize%22,"/",%22Insert Module%22,%22Draw%22,%22Attachment%22,%22Wanted Pages%22],
language: "en",
customConfig: "",
autoSaveSelf: "jamesarm97:wiki_page:test", // unique reference for each page set up in ensureReferrer()
font_names: "sans serif;serif;monospace;Arial;Century Gothic;Comic Sans MS;Courier New;Tahoma;Times New Roman;Verdana",
format_tags: "p;h1;h2;h3;h4;h5;h6",
stylesSet: "tikistyles:/lib/ckeditor_tiki/tikistyles.js",
templates_files: %22/lib/ckeditor_tiki/tikitemplates.js%22,
skin: "moono",
defaultLanguage: "en",
contentsLangDirection: "ltr",
language: "en"
,height: "400"
, resize_dir: "both"
, allowedContent: true
});
CKEDITOR.on("instanceReady", function(event) {
if (typeof ajaxLoadingHide == "function") { ajaxLoadingHide(); }
this.instances.editwiki.resetDirty();
});

hi

not sure if I remember right, but there was some issue whether codemirror was switched on or off, maybe you can try that

also try switch off minify javascript

please create a demonstration bug report on dev.tiki.org if these does not help

cheers,

gezza

USA

It was the minify Javscript that broke it. Thanks.

- James

 


Indonesia

Hi:
I was going to create a thread about this issue as well. In my case:

Settings are:

  • TW14.2
  • Cache: Cleaned
  • Full Wysiwyg editor: Ticked
  • Use Wiki syntax in WYSIWYG: Ticked
  • Full Wysiwyg editor skin: Office 2003 (tried in Moono and the problem is the same)
  • Full Wysiwyg Editor is displayed by default: Ticked
  • Full Wysiwyg Editor is optional: Ticked
  • Reopen with the same editor: Ticked
  • Allow HTML: NOT Ticked
  • HTML pages: NOT Ticked
  • Plugin HTML: Ticked
  • Plugin WYSIWYG: Ticked
  • Can switch between wiki and WYSIWYG modes while editing (tiki_p_edit_switch_mode) ticked
  • Content is parsed like wiki page: Ticked


Even with full admin rights in /tiki-edit_article.php I can see the title box, heading box but no Body box
POST 1

In /tiki-editpage.php I can see the edit page but not the WYSIWYG editor
Post3

The only way to edit something is to untick Full Wysiwyg editor.

After further thinking, the problem came from the Minify JavaScript.

Did the following test:

  1. Minify JavaScript unticked: WYSIWYG works OK.
  2. Clean Cache
  3. Minify JavaScript ticked and clean cache: WYSIWYG editor does not show up.
  4. Untick again Minify JavaScript and WYSIWYG works again properly.


So the problem comes from Minify JavaScript and Wysiwyg. Even cleaning the cache did not help.

Not sure if it's a bug or a local problem of some installations.

Regards,
Pak


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.