Loading...
 
Architecture / Installation

Architecture / Installation


Re: Looping to Tiki Installer Security Precaution screen on upgrade from 18.1 to 18.3

posts: 8049 Israel

Ahem...
We are talking about an package release correct ? (not SVN)

The loop look to me like something wrong with the DB access.

  1. DB access
    Check db/local.php and use those credentials to connect to the DB using SSH or PHPmyAdmin to check the credentials are rights and this MySQL user has all the permissions granted.
    If you can access and have all rights on the DB with the user and password then Tiki should be ok.
  2. Files permissions and ownership
    You need to check your files have right permission and ownerships (may be something prevent local.php to be written or updated properly)
    I would use
    sh setup.sh
    from the tiki folder root - option f. I guess you re-run several the installer already... But in case of...
  3. Update the database
    warnings that my database is not upgraded

    As long as you have this one your attempts will fail as they were a lot of changes from 18 to 19 that need to be applied to the DB.


Again if you are online next Thursday... ;)

Join our Tiki Open Online Hours session every first, second and fourth Thursday of the month and receive support from a Tiki consultant online for free.

posts: 1

Same here! with new installation, get the Tiki Installer Security Precaution LOOP!
Steps mentioned
1. DB Access (is fine!)
2. sh setup.sh done (www-data.www-data)
Problem persists!
Nginx, Tiki creates session in /tmp but obviously cant refer to it or read it, though owner www-data.


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.