Loading...
 
Features / Usability

Features / Usability


Wiki3d does not work

I have upgraded from 1.8 so I can use the wiki3d feature, but cannot get it to work.

Clicking on the wiki3d link brings up a new window with a java applet. But the applet remains blank. The java console report the following messages
java.lang.NullPointerException

at br.arca.morcego.GraphDataRetriever.retrieveData(GraphDataRetriever.java:72)
at br.arca.morcego.Morcego.start(Morcego.java:130)
at sun.applet.AppletPanel.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

java.lang.NullPointerException
at br.arca.morcego.Morcego.paint(Morcego.java:325)
at sun.awt.RepaintArea.paint(Unknown Source)
at sun.awt.windows.WComponentPeer.handleEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


Just to see what's going on I have loaded the xmlrpc php directly into the browser and get the following error messages from both xmlrpc.php and tiki-xmlrpc_services.php

Fatal error: Cannot redeclare xmlrpc_decode() in /var/www/html/tikiwiki19/lib/xmlrpc.inc on line 1017

I got the same error using 1.8.4

wiki3d works fine on this site and looks really good.

Any ideas?



Japan

You're not alone. It doesn't work for me either in Tiki 1.9rc2. Maybe upgrading to the latest CVS version would make a difference — I don't know.

-- Gary


United Kingdom

Hi guys.

What version of Java have you got installed?

There isnt alot we can do anyway. Batawata commited only the .jar file we dont have current source code to fix cry

Damian
Project Admin


I am not sure that it is a java issues as the map on this site works fine. I am most worried about the failure of the xmlrpc php files to work properly.

It looks as if other people have these working on their sites, but I get the php error

Fatal error: Cannot redeclare xmlrpc_decode() in /var/www/html/tikiwiki19/lib/xmlrpc.inc on line 1017

Could this be because I have updated the database several times through several editions? This seems unlikely as it is only the database that remains from these earlier versions.

Jim

i'm getting the same error message, but my problem is related to troubleshooting a blogging client xmlrpc connection that stopped working when my hosting company changed servers on me.
help.


Hi, according to ang, mod_php must be compiled with xmlrpc support...

I hope this works.

tl

maybe i should shut my mouth... :-)

I've renamed the xmlrpc_encode and xmlrpc_decode functions to _xmlrpc... and now it works...

I hope that this really helps... :-)

> I've renamed the xmlrpc_encode and xmlrpc_decode functions to _xmlrpc... and now it works...
>
> I hope that this really helps... :-)

The lack of discussion on the Wiki 3D thing bothers me since it is such a COOL feature with enourmous possiblities. I have been hunting forever for a fix. i get the same problems. they seem to be centered around bad communication.

If your fix works for me that would be great. however i am having problems finding out exactly where you performed your fix. Can you give me the filename(s) and the exact relative location of those files. This would be most helpful. thank you.


United Kingdom

Odd - i'm getting a blank page here (Exception in thread "AWT-EventQueue-13" java.lang.NullPointerException at br.arca.morcego.Morcego.paint Morcego.java:325) but it works fine on the demo site: http://morcego.utopia.com.br/.

Sounds like an update might be possible?

This is in XP SP2, IE6, Sun Java 1.5

btw, Mac OS X is far more of a basket case on both sites so i have added this to the Morcego bug report list.

Hope this gets fixed or is fixable soon as it's a great toy!

jonny B

Yeah it is not working for me as well. I am using a Windows 2003 Server for the wiki with both Mozilla and IE7 and I have also tested on IE6 and Sun Java and I also receive a blank screen. I started to try and debug the page and received the following java errors:

org.apache.xmlrpc.XmlRpcException: Unknown method
at org.apache.xmlrpc.XmlRpcAppletClient$Worker.execute(XmlRpcAppletClient.java:457)
at org.apache.xmlrpc.XmlRpcAppletClient.execute(XmlRpcAppletClient.java:163)
at br.arca.morcego.transport.XmlrpcTransport.fetchData(XmlrpcTransport.java:131)
at br.arca.morcego.transport.XmlrpcTransport.retrieveData(XmlrpcTransport.java:83)
at br.arca.morcego.run.Feeder.run(Feeder.java:138)
at java.lang.Thread.run(Unknown Source)
java.lang.NullPointerException
at br.arca.morcego.transport.XmlrpcTransport.fillGraph(XmlrpcTransport.java:93)
at br.arca.morcego.transport.XmlrpcTransport.retrieveData(XmlrpcTransport.java:85)
at br.arca.morcego.run.Feeder.run(Feeder.java:138)
at java.lang.Thread.run(Unknown Source)


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.