Loading...
 

InstallEclipseRedhat

key link http://people.redhat.com/~jhealy/eclipse/

Case Study

It was a bit of a saga, I would have loved an apt-get repository to solve all of my dependancies because the above site doesn't list all of them... in fact there's a dupe link on the above site. I'll give you the breakdown of what I needed to install eclipse on my RH9 box

Now I use apt-get a lot but some of these I had to go digging for at http://rpmfind.net/linux/RPM/index.html

rpm -ivh oprofile-0.5.4-3.i386.rpm
rpm -ivh db4-4.1.25-4.i386.rpm
rpm -ivh libstdc++-ssa-3.5ssa-0.20030617.24.i386.rpm
rpm -Uvh libgcc-3.3-14.i386.rpm
rpm -ivh libgcj-ssa-3.5ssa-0.20030617.24.i386.rpm
rpm -ivh snapshot-20030802-eclipse-2.1.0-12.i386.rpm

There are multiple dependancies involved. Save time by getting all of them into your dowload folder and then rpm -ivh to your heart's content. I think the above order is pretty accurate... at least it should be as I lifted it from my .bash_history. Oh, and be sure to updatedb from time to time.

When you're done try at the command line:
eclipse

You've installed 2.01, note 3beta is already in the works at eclipse.org so you won't be getting all the bells and whistles. Furthermore, Eclipse is not yet ready for PHP partly because the plugins for PHP via http://phpeclipse.sourceforge.net/en/quick_start.php are only for 2.1 rendering this particular install "a proof of concept".

I'll give it a shot with JgraphPad now.
More soon on using eclipse and the TikiCvsHowTo.


Page last modified on Wednesday 06 August 2003 18:46:12 GMT-0000

Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.