Loading...
 

ReleaseNotes42

Release Notes

Installation

When installing Tiki 4.0 with PHP 5.1.0 (or higher), you may encounter a System error: could not find driver message. This indicates that PDO driver for your database has not been enabled on your server.

To enable the driver:

  • For Unix:
    Refer to http://us.php.net/manual/en/book.pdo.php] for information on installing PDO support.
    As an alternative, add the following statement to the end of your ../db/local.php file, before the ?> :
    $api_tiki='adodb';

  • For Windows:
    Add the following statement to your php.ini file:
    extension=php_pdo_mysql.dll

Upgrade

You can upgrade your 1.9.x, 2.x, 3.x, or 4.x Tiki directly to this release by using the Tiki Installer. See http://doc.tiki.org/Upgrade

In this Release

New Features


Authentication

  • Full support for OpenID
  • Multiple improvements for LDAP authentication


Articles

  • Assign default size for images


Wiki

  • Allow wiki comments on a per-page basis


General

  • Multiple theme, CSS, and UI improvements

Fixes

  • Security fix, as reported by Mateusz Drygas
    Alert All 3.x and 4.x are strongly encouraged to upgrade to the this release.
  • Bug fixes:



alias

Page last modified on Friday 20 September 2019 16:22:05 GMT-0000

Upcoming Events

1)  Wed 23 Sep 2020 14:00 GMT-0000
September TRM

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.