Loading...
 

ReleaseNotes5.1

Tiki 5.1 Release Notes

Release Notes
information This document includes important information about Tiki 5.1. Please review this information when installing (or upgrading to) this release.


For Tiki support, please use the forums.

Quick links: Changelog | Tiki5 (doc) | Tiki5 (dev) | Upgrade | Roadmap

Introduction to upgraders from earlier versions

If you are migrating to Tiki5 from Tiki versions earlier than Tiki4, you are encouraged to read first the pages describing the changes introduced in earlier versions of Tiki, such as:


as well as the page linking to the resources related with Upgrades

If this is your first installation ever of Tiki, welcome to Tiki Community! You'll find details about the installation here:

New features

This is a bugfix release, there are no new features compared to Tiki5

Database Encoding

By default, Tiki uses UTF-8 database encoding. If your database uses different encoding, the Tiki Installer will display a warning message.

The Tiki Installer includes an option that will attempt to fix your database and change the encoding to UTF-8.
Note: Backup your database before attempting this fix.

If you are upgrading from previous tiki versions, please follow once the 3 steps documented here:
http://doc.tiki.org/Upgrade#Fix_the_encoding_issue

Category Permissions

Category permissions have been dramatically revamped and improved since version 3. When upgrading to version 5.1 from version 3.x (or earlier), your permissions may not migrate properly. You should review the category permissions and reconfigure them, if necessary.

Refer to http://dev.tiki.org/Permission+Cleanup for information on these changes, and http://doc.tiki.org/permission for complete information on Tiki permissions.

Known Issues


"Upgrade" Warning on New Installs

When performing a new Tiki 5.1 installation on a new database, the Tiki Installer may display the following warning:

Upgrading and running into encoding issues?

The warning erroneously says "upgrading" even though you are running a brand new installation.


Installation Fails on PHP 5.3.0

When installing Tiki5 on PHP 5.3.0, installation may fail with the following message:
Fatal error: Undefined class constant 'MYSQL_ATTR_INIT_COMMAND'

This is due to a known bug with PHP 5.3.0. To install Tiki 5.1, use a newer PHP version.

Loss of Admin Privileges

When upgrading to version 5.1 from some Tiki versions older than 3.0, you may experience Permission Denied messages for some features, even when logged in as the administrator (Admin) user. If your Admin account has lost permissions, you can easily recover them.

  1. After completing the upgrade, re-run the Tiki installer (tiki-install.php).
  2. Go directly to Step 7. Configure the General Settings.
  3. At the bottom of the page, in the Upgrade Fix area, enter the name of your administrator account. The default name is admin.
  4. Click Continue.

Tiki will:

  • Create a new Admins user group.
  • Grant tiki_p_admin to the group, if missing
  • Add the specified administrator account to the group.


Characters replaced by question marks e.g. in wiki pages when running on UTF-8

  • So your db and all your tables are UTF8? (you can double check it in phpmyadmin)
  • and your db/local.php has a $client_charset='utf8'; and not a $client_charset='latin1';?
  • and you get question marks when you add some non-English characters to your wiki page?
  • then you have this issue, and you shall try to add $api_tiki='adodb'; to your db/local.php, because it worked for me. Ref: Date: Tue, 14 Sep 2010 09:21:03 -0400 From: marclaporte To: tikiwiki-devel Subject: Re: Tikiwiki-devel UTF-8 in TW5.1

Further reading: Understanding encoding, UTF8


alias


Page last modified on Friday 20 September 2019 16:22:40 GMT-0000

Upcoming Events

1)  Wed 23 Sep 2020 14:00 GMT-0000
September TRM

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.