Loading...
 
Architecture / Installation

Architecture / Installation


Re: Re: Tiki 2 - suggested ssh command not allowing me to process file directories for Mods

posts: 1797 Catalan Countries

Hi Michael

Xavi, or anyone else that can assist.
I was looking at your resume Xavi, pretty impressive. Thank you for all your hard work and support with Tikiwiki and it's educational contexts. I am a technical teacher, mostly at the high school level, with occasional teaching of University, so I can relate to your efforts.

I thank you for your advice and will wait with Tikiwiki 2 and the Aulawiki mod, as that will save me a lot of grief. In the meantime I will work on brining tikiwiki 2 into my web design and layout.

Thanks

I still have 1.9.11 installed and would still like to see how this mod actually works for set-up in the future and how best I can use it with my students at the technical high school level(Good idea or not?). Maybe you can help me a little bit with this.... two issues then:

1) I tried to install the current Aulawiki 1.6 on Tikiwiki 1.9.11, but I get errors and it was suggested by tasmaniac that Aulawiki 1.6 was designed Tikiwiki 2.
http://tikiwiki.org/tiki-view_forum_thread.php?comments_parentId=29554&topics_offset=15&topics_sort_mode=lastPost_desc&forumId=6 (external link)?
Anyway you mentioned that Aulawiki 1.5 works well with 1.9x. If that is the case, would 1.5 be recommended to use instead and if so, where would I get a previous release of Aulawiki (1.5)?


Try getting it from here:
http://edu.tikiwiki.org/mods/Cache/features-aulawiki-1.5.tgz

2a) The other issue is ssh commands with respect to set-up for Aulawiki install. My host provider initially ran the sh script for Tikikwiki 1.9.11 to allow me to install the Aulawiki mod. I also recently gained access to ssh command line entry to my host web site which is not the norm for my host provider. I have been able to enter in basic commands with no problem, but whenever I try to use the ./fixperms.sh fix in my tikiwiki folder, it does not work, but it may have to do with the settings required which I am not sure of:
Log:
cd mainwebsite_html
-bash-3.1$ cd tikiwiki
-bash-3.1$ ./fixperms.sh fix
You are not root or you are on a shared hosting account. You can now:

1- ctrl-c to break now.

or

2- If you press enter to continue, you will probably get some error messages but it (the script) will
still fix what it can according to the permissions of your user. This script will now ask you some
questions. If you don't know what to answer, just press enter to each question (to use default value)

Group nobody:
Multi []:
Checking dirs :
backups ... ok.
db ... ok.
dump ... ok.
img/wiki ... ok.
img/wiki_up ... ok.
img/trackers ... ok.
modules/cache ... ok.
temp ... ok.
temp/cache ... ok.
templates_c ... ok.
templates ... ok.
styles ... ok.
maps ... ok.
whelp ... ok.
mods ... ok.
files ... ok.
lib/Galaxia/processes ... ok.
Fix global perms ...chown: `webadmin:nobody': invalid group
chowned ...chmod: changing permissions of `./tiki-pick_avatar.php': Operation not permitted

.... and all further operations not permitted, so I am assuming that the Group nobody: should be set to something else and I am not sure what Multi []: should be set to. Any suggestions here?

Mmm, try writing "nobody", "apache" or "www-data" (without quotes) as answer to the question

Group nobody:


forget Multi, if you are not using multitiki

Anyway, the install mods interface didn't work under some scenarios, I don't know why. You can do the manual installation, which always worked for me (as far as the Mod worked once installed):
http://doc.tikiwiki.org/Mods

Ask again if in doubt, and/or help us improve the documentation about manual installation of mods, once you succeed and you have your doubt answered, if any.

2b) In Tikiwiki 2, to add or see any mods I need to run another script shown in a red box in the Admin Mods window:
You need to run setup.sh :
./setup.sh $APACHEUSER all
Common Apache users are www-data, apache or nobody
Again I run it... log:
-bash-3.1$ cd mainwebsite_html
-bash-3.1$ cd pages
-bash-3.1$ cd wiki
-bash-3.1$ ./setup.sh $APACHEUSER all
-bash: ./setup.sh: Permission denied
-bash-3.1$

I know I am new with this sh command stuff and I have been successful with basic commands, but with the two wiki versions, I can't seem to get any of the commands to work. The previous tiki version 1.9.11 is probably just entering the right group, but tiki 2, no idea.
Any ideas on why this command is not working also?


Try adding this step (chown +x setup.sh) before attempting to run setup.sh:

-bash-3.1$ cd mainwebsite_html
-bash-3.1$ cd pages
-bash-3.1$ cd wiki
-bash-3.1$ chown +x setup.sh
-bash-3.1$ ./setup.sh $APACHEUSER all


However, as I said before, manual installation of the mod might be faster, is you face more problems on your server to install tiki mods through admin interface.

By the way Xavi, I noticed the sample workspace link for the Aulawiki mod takes you to a page where it says the workspace is closed. Would love to see this mod in action somewhere, any possibility of reviving the workspace sample?


I know, I know :-/. See this
I'm looking forward that some coders fix aulawiki to work on 2.0, so that I can edit properly that workspace on edu.tw.o and open it up again.
A fix and enhancement seems to be in the way... See the new prototype through here:
http://edu.tikiwiki.org/tiki-index.php?page=AulaWiki

... anyone else, you are welcome to jump in because if I am having these problems, most likely there are others with the same issue.

Michael


If I see any other easier way to test AulaWiki, I'll tell you, Michael (I think I packed it on a previous version of the TikiLiveCD with Tiki 1.9.x - both working fine... I'll see if I find which version of the CD...)

Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.