Loading...
 
Themes

Themes


Jqui theme and top bar in TikiWiki 7.0

Hi,

I recently installed TikiWiki 7.0 and tried to get everything like in my old 6.2 installation. Something that I can't get to work is the layout of the top bar with the small search box on the left:

url=http://imageshack.us/photo/my-images/38/tikiwithsearchbox.png/IMGhttp://img38.imageshack.us/img38/7356/tikiwithsearchbox.th.png/IMG/url

How do I enable this? Fresh install of 7.0, no settings changed except switched to the Jqui theme and enabled the "Search" feature, of course.

bagstone wrote:

Hi,

I recently installed TikiWiki 7.0 and tried to get everything like in my old 6.2 installation. Something that I can't get to work is the layout of the top bar with the small search box on the left:

http://imageshack.us/f/38/tikiwithsearchbox.png/

How do I enable this? Fresh install of 7.0, no settings changed except switched to the Jqui theme and enabled the "Search" feature, of course.


Japan

Can you check to make sure the "search" module is assigned (on the tiki-admin_modules.php page) to the "topbar" module zone? It should have the compact and nobox parameters. This should be all that's necessary (actually should have been like this by default, but maybe some problem occurred).

-- Gary

Wow, thanks for that quick response!

This is how the module page looks for me:

http://imageshack.us/f/402/modulepage.png/

As you can see, there is no search module. And there is no proper CSS applied either, what makes it hard to navigate on this page ;-) If I click on "add module", nothing happens. I activated the Search on the "Features" page of the admin section.

Czech Republic
bagstone wrote:

Wow, thanks for that quick response!

This is how the module page looks for me:

http://imageshack.us/f/402/modulepage.png/

As you can see, there is no search module. And there is no proper CSS applied either, what makes it hard to navigate on this page ;-) If I click on "add module", nothing happens. I activated the Search on the "Features" page of the admin section.


no CSS applied indicates low memory_limit set for your PHP or execution time-out

luciash d' being 🧙‍♂️ wrote:
no CSS applied indicates low memory_limit set for your PHP or execution time-out


Yeah sounds like that, but doubt that (it's displaying instantly, btw). See phpinfo here:

https://tiki.org/tiki-view_forum_thread.php?forumId=4&comments_parentId=41516&comments_per_page=1&thread_style=commentStyle_threaded

However, I'm probably staying with 6.2 (i.e., switching to 6.3 soon), as it seems that almost all my problems are fixed with that version and I don't need any new features right now.


Japan

For the record, your screen image shows the "Top" modules zone, not the "Topbar" zone where the search module would be listed, to be displayed where you want it. It isn't obvious without the CSS being applied, but the module zone assignments are shown in a set of tabs, and just the "Top" zone tab is visible in the screenshot.


-- Gary


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.