Loading...
 
Documentation

Documentation


Re: Re: Re: Unable to assign custom module

posts: 2417 Czech Republic

Seems you do use HTML wikiplugin in the module.
If it is true, you need to make sure "Must be wiki parsed." checkbox is enabled in the Modules Admin while editing the custom module on the Custom Modules tab.
That brings me to the thought: Why do you use the HTML plugin there ? Is it a must ? If the answer is No or I do not know, simply remove the HTML plugin syntax from there and use just the HTML code directly there and you do not need the module to be wiki parsed at all.

luci


{QUOTE(replyto=>littledove)}Hi Luci,

The "Smarty Template usage indicator" on Features > Programmer Admin panel was not enabled, but I turned off "Include Smarty Notices" in the Logging and Reporting area nearby.

Create new module, try to assign it and get this:

"Fatal error: Uncaught exception 'SmartyCompilerException' with message 'Syntax Error in template "eval:" on line 1 "{HTML(wiki="0")}<img src="http://forwardlinkprotocol.com/8.3/id/images/web_compendia3-150sq-tag.gif" height="150" width="150" alt="Web Compendia logo" imalign="left"><br />" - Unexpected "=", expected one of: "","" , ")"' in /home/webcompe/public_html/forwardlinkprotocol.webcompendia.org/8.3/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php:439 Stack trace: #0 /home/webcompe/public_html/forwardlinkprotocol.webcompendia.org/8.3/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(2889): Smarty_Internal_TemplateCompilerBase->trigger_template_error() #1 /home/webcompe/public_html/forwardlinkprotocol.webcompendia.org/8.3/lib/smarty/libs/sysplugins/smarty_internal_templateparser.php(2954): Smarty_Internal_Templateparser->yy_syntax_error(19, '=') #2 /home/webcompe/public_html/forwardlinkprotocol.webcompendia.org/8. in /home/webcompe/public_html/forwardlinkprotocol.webcompendia.org/8.3/lib/smarty/libs/sysplugins/smarty_internal_templatecompilerbase.php on line 439"

Thanks for responding!

-littledove{QUOTE}