Loading...
 
Features / Usability

Features / Usability


Ampersand and Greater Than displaying as HTML

United States

I just upgraded to 9.2 from 8.1 and noticed that on some of my wiki pages the ampersand "&" and greater than ">" characters are being displayed by their HTML equivalents ("&amp", and "&gt").

I did not have this issue with 8.1. The issues occurs on some wiki pages but not on others.

When I view the document in the edit pane it shows the correct character, and all I have to do is click save (without actually editing anything) and the HTML goes away. Not sure why/how, but the edit pane and preview pane correct the issue.

I'm guessing something happened during the upgrade, but I'm not sure why it only affected some wiki pages and not others. Good news is that is is an easy fix, but a PITA and will require editing and re-approving hundreds of pages.

Anyone else have this issue while upgrading? Know any any easier fixes or how to prevent it during future upgrades?

Canada

This is a strange one indeed. And a little worrisome that it's on some but not all pages. Can you detect a pattern?

Between 8.x and 9.x, there was a fix concerning HTML entities. This solves the false positives we used to get in diffs. Ref: http://tiki.org/ReleaseNotes9.0#HTML_entities

Do you think you could have it investigated/resolved the same way you did for Flagged revision reports?

Thanks!

United States

Credit for the flagged revisions reports goes to LP Huberdeau, I just encouraged the development wink.

I'm going to finish reading through the history of this issue and solutions on Newsgroups: gmane.comp.cms.tiki.devel, Subject: Re: Tiki-devel Decoding HTML special characters in page sources.

I will then try to find some sort of pattern on my pages and will report back here.


United States

The issue is on all pages which have not been edited since upgrade to 9.2.

Any page versions which were awaiting Flagged Revision approval (latest) dont show the issue in the latest version. This is what lead me to believe the issue was only on some pages.

My work around is going to be to edit/save/approve each (500+) page.


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.