Loading...
 
Features / Usability

Features / Usability


How to extend the range of the DatePicker in Blogs?

posts: 18 United States

Greeting,
How do you extend the range of the datepicker when editing a blog? The year ranges from 2013 to 2028 in Tikiwiki 18.1. I would like to edit old blogs dating back to 2010, but can't select dates older than 2013.

posts: 18 United States

Hi Bernard,
I tried that using -10 as the start date and then with 2009 but the date picker range is still 2013 to 2028. The default was set to -3 so that start date should have been 2015 not 2013. This occurs in the date picker in a new post and in editing a post. Any suggestions? Docs indicate that the date picker is associated with the JQuery UI. Could the date rage be set in that feature?

posts: 18 United States

Hi Bernard,
The URL is at https://www.p-brane.com/
I invite you to become a user and try creating a blog post with a date earlier than 2013.

The photo below gives you an example. I've upgraded Tikiwiki many times since 2010 and did not notice that image syntax changed at some point so I've been updated old posts to work properly. When I make a change the post get out of date order because I can save the changes earlier than 2013.



posts: 8357 Israel

Thanks for the details.

I tested and reproduce the issue and I confirm something is wrong with date range.
Start year and End year from Control Panel -> General -> Time and Date are not applied on blog.

Test with blog:
Screen Shot 2018 03 17 At 09.50.17

Test with article:
Screen Shot 2018 03 17 At 09.52.15

Best course of action is to go at : https://dev.tiki.org/Make-a-wish
Create a report for the issue (much details as possible).
I would have suggest you to create an instance on a 18.x to give a perfect use case for our developper to understand properly and quickly the issue, but actually our instance systems are down.
Our Sys Admin team has been contacted.


posts: 18 United States

Hi Bernard,
I created a ticket (6599) and an instance but the instance failed due to lack of third party drivers.

Is the fix simple enough that I can it do myself? What needs to be changed?