Loading...
 
Architecture / Installation

Architecture / Installation


Re: Re: 1.7.6 update to 1.8.2--Impossible?

posts: 2881 United Kingdom

> blacklily8:
> I was finally able to update my 1.7.3 site to a 1.8.2. The task was difficult, and I doubt that anyone without considerable patience and extensive experience with mysql and shell would be able to accomplish such a feat. Clearly, the update scripts need an overhaul.
>

tiki-install needs a rewrite.

> The biggest problem I encountered was with the comments fix. It took me hours to finally recover the old messages from my 1.7.3 forums. The problem was that the script was looking for non-existent columns in my old comments directory. Thankfully, I made backups of everything before running the scripts, and didn't lose anything.

mmm, did you run comments fix after the 1.7to1.8 update script? I havent experienced any problems upgrading any of my 1.7 tiki sites, including doc.tikiwiki.org.

> This is an obvious and major flaw in the update scripts that ought to be immediately addressed.

You welcome to contribute. Personally Ive not experienced problems. Without a database with problems I have no bugs to kill.

> The other major problem I had during installation was with the setup.sh script. It didn't work before, but magically worked today. I have no clue why or how. This problem should also be addressed with the wiki team.

again, without it happening here, or more frequently intermittent bugs are a problem to trace and kill.

> Guys, no matter how great and wonderful tikiwiki is, if it's difficult for people to install it, it won't catch on. We really need to spend time on documentation and ensuring that the install instructions/scripts work. I consider myself a pretty resourceful guy when it comes to this stuff, but this update was DIFFICULT and extremely time-consuming (we're talking days here.)

1.7 to 1.8 update was very awkward, 1.8 to 1.9 will be an easier upgrade, and I think for 2.0 we will rewrite the installer completely.

> If tikiwiki is to be successful, we will need to ensure that it installation is fairly easy. We can assume some level of knowledge, but not advanced skills like editing scripts or working with shell. Please!

Damian

Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.