Loading...
 
Architecture / Installation

Architecture / Installation


Upgrade Tiki18 to 21 Error

posts: 8319 Israel

Hello John,

I’ve seen this kind of error two or three times with older tiki being updated several times (from version to version to another version, etc).

This is a PHP error that comes from something that was "accepted" before (while it was not intended) and now with PHP7 (more strict I guess) it is causing an error.

The last case I remember;
A tiki user filling his articles author fields with an email address instead of a user name or a regular text string. It was working before (somehow) but causes the same king of error in an article plugin on its home page after moving to PHP7 (or 7.2 ?).

Try to check what this "piwik_plugin" is used for ?
(can be one of you plugin or the Piwik Admin panel setting - a lot are built around plugins).

If you don’t use it, reset all values to default or delete the plugin.

Let us know ;-)