Loading...
 
Architecture / Installation

Architecture / Installation


Glitches with Ubuntu Server 20.04?

posts: 953
aristo compasso wrote:

Hi all,

I was wondering if anyone has experienced glitches on Ubuntu Server 20.04? Some 3 months ago I installed Tiki 21.0 on that system, and although everything seemed ok at first, I started noticing a few bugs , like some selected options weren't applied, some plugins gave errors when enabling, could not access profiles.tiki.org and apply any profile... among others.

I subsequently installed Tiki on Ubuntu Server 18.04 and verified none of those bugs occurred.
Now I have to install Tiki on another Ubuntu system, hopefully on 20.04, but would like to be reassured it's now working perfectly with Tiki 21.1.

I'd appreciate any comments regarding this issue.
All the best,

If it's a production server to use with Tiki, I would recommend to go for Ubuntu 18.04 (way more tested by many of us.
For instance, I just recently upgraded some computers to ubuntu 20.04 (and php 7.4, etc) and I'm touching some oddities.... so go for Ubuntu 18.04 for production, and lease, help to improve the documentation page on doc.t.o about Ubuntu Install with your findings with Ubuntu 2.04:
https://doc.tiki.org/Ubuntu+Install

Please please add bug reports with your findings on ubuntu 20.04 at the bug tracker:
https://dev.tiki.org/File+a+bug
(some bugs may show up with the newer versions of mysql and/or php being used in ubuntu 20.04, etc, and maybe being more strict than earlier versions in some aspects, etc.

HTH)