Loading...
 
Features / Usability

Features / Usability


Re: SMTP Settings

United Kingdom

Tiki uses PHP's mail command, so the outgoing email is setup in php.ini

part II requires a little code to automatically add people to the watch forum mailings/

Damian

Hi Tiki Gurus:

So far I am only able to configure an SMTP server in php.ini and have tiki send email successfully if this SMTP does not require authentication.

However, I have another tiki at home and my ISP (which is SMTP/POP) requires authentication. Where in the PHP.INI or in TIKI code should I provide my ISP's username/password so that it can send email for notification or for new registered users? Without providing username/password to my ISP, no email is sent. I tested by adding a boolean test to the mail(...) code in tiki-register.php, and the result was false.

Please help! Thanks!

I had a similar kind of problem and after debugging for 2 months managed to solved it.

I use xampp to deploy my tikiwiki. If are using a similar deployment, follow these steps to solve the problem

1) Open php.ini and uncomment extension=php_smtp.dll
2) Also uncomment sendmail_path = "C:\xampp\sendmail\sendmail.exe -t" , Ur path will be different
3) Now go to sendmail directory, open sendmail.ini, uncomment and fill with the required details like smtp_server, smtp_port=25,auth_username and auth_password
4) Also uncomment error_logfile=error.log and debug_logfile=debug.log for debugging purpose

Restart the server, now you can authenticate again smtp server for sending emails.

Hope it helps

Bhaskaran
http://www.mytrekexperiences.com


Hi Tikigod!

So far I am only able to configure an SMTP server in php.ini and have tiki send email successfully if this SMTP does not require authentication.

However, I have another tiki at home and my ISP (which is SMTP/POP) requires authentication. Where in the PHP.INI or in TIKI code should I provide my ISP's username/password so that it can send email for notification or for new registered users? Without providing username/password to my ISP, no email is sent. I tested by adding a boolean test to the mail(...) code in tiki-register.php, and the result was false.

Please help! Thanks!

I had a similar kind of problem and after debugging for 2 months managed to solved it.

I use xampp to deploy my tikiwiki. If are using a similar deployment, follow these steps to solve the problem

1) Open php.ini and uncomment extension=php_smtp.dll
2) Also uncomment sendmail_path = "C:\xampp\sendmail\sendmail.exe -t" , Ur path will be different
3) Now go to sendmail directory, open sendmail.ini, uncomment and fill with the required details like smtp_server, smtp_port=25,auth_username and auth_password
4) Also uncomment error_logfile=error.log and debug_logfile=debug.log for debugging purpose

Restart the server, now you can authenticate again smtp server for sending emails.

Hope it helps

Bhaskaran
http://www.mytrekexperiences.com


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.