Loading...
 
Features / Usability

Features / Usability


1.9.2 html rendering in Articles gone?

posts: 13 United States

With 1.9.2 is rendering of HTML in Tiki Articles now expressly unavailable for security reasons?

Or is it broken?

Enabling Admin->Wiki->AllowHtml doesn't seem do the trick either.

--Art

posts: 1092

Seems to be broken in preview. article
I have no problem with wiki (preview+ view) and article (view).
Can you give more information.
Thanks
sylvie

posts: 13 United States

> Seems to be broken in preview. article
> I have no problem with wiki (preview+ view) and article (view).
> Can you give more information.
> Thanks
> sylvie

For me, wiki view and preview render html OK.
Interestingly, if I disable Admin->Wiki->AllowHtml, wiki view still renders html but wiki preview does not.

Article view and preview do not render html for me... the just show up as cleartext.

I installed 1.9.2 from the sourceforge tarball and ran the included 1.9.1to1.9.2.sql database update.

(Underlying software is: php4-4.4.0, mysql-4.1.15 and apache-1.3.34)

Thanks!

--Art

posts: 13 United States

> > Seems to be broken in preview. article
> > I have no problem with wiki (preview+ view) and article (view).
> > Can you give more information.
> > Thanks
> > sylvie
>
> For me, wiki view and preview render html OK.
> Interestingly, if I disable Admin->Wiki->AllowHtml, wiki view still renders html but wiki preview does not.
>
> Article view and preview do not render html for me... the just show up as cleartext.
>
> I installed 1.9.2 from the sourceforge tarball and ran the included 1.9.1to1.9.2.sql database update.
>
> (Underlying software is: php4-4.4.0, mysql-4.1.15 and apache-1.3.34)
>
> Thanks!
>
> --Art

OKdoke. I've found out I didn't have the right permissions set. If I make sure the viewing user has tiki_p_use_HTML permission, then HTML in article view DOES render (and not so in article preview).

--Art

--Art

posts: 13 United States

> > > Seems to be broken in preview. article
> > > I have no problem with wiki (preview+ view) and article (view).
> > > Can you give more information.
> > > Thanks
> > > sylvie
> >
> > For me, wiki view and preview render html OK.
> > Interestingly, if I disable Admin->Wiki->AllowHtml, wiki view still renders html but wiki preview does not.
> >
> > Article view and preview do not render html for me... the just show up as cleartext.
> >
> > I installed 1.9.2 from the sourceforge tarball and ran the included 1.9.1to1.9.2.sql database update.
> >
> > (Underlying software is: php4-4.4.0, mysql-4.1.15 and apache-1.3.34)
> >
> > Thanks!
> >
> > --Art
>
> OKdoke. I've found out I didn't have the right permissions set. If I make sure the viewing user has tiki_p_use_HTML permission, then HTML in article view DOES render (and not so in article preview).
>
> --Art
>

...scratch that permission thing. It was a red herring. Here's the breakdown:
tiki-view_articles.php -> Does not render html
tiki-read_article.php -> Does render html
tiki-edit_article.php -> Preview does not render html

--Art

posts: 13 United States

> > > > Seems to be broken in preview. article
> > > > I have no problem with wiki (preview+ view) and article (view).
> > > > Can you give more information.
> > > > Thanks
> > > > sylvie
> > >
> > > For me, wiki view and preview render html OK.
> > > Interestingly, if I disable Admin->Wiki->AllowHtml, wiki view still renders html but wiki preview does not.
> > >
> > > Article view and preview do not render html for me... the just show up as cleartext.
> > >
> > > I installed 1.9.2 from the sourceforge tarball and ran the included 1.9.1to1.9.2.sql database update.
> > >
> > > (Underlying software is: php4-4.4.0, mysql-4.1.15 and apache-1.3.34)
> > >
> > > Thanks!
> > >
> > > --Art
> >
> > OKdoke. I've found out I didn't have the right permissions set. If I make sure the viewing user has tiki_p_use_HTML permission, then HTML in article view DOES render (and not so in article preview).
> >
> > --Art
> >
>
> ...scratch that permission thing. It was a red herring. Here's the breakdown:
> tiki-view_articles.php -> Does not render html
> tiki-read_article.php -> Does render html
> tiki-edit_article.php -> Preview does not render html
>
> --Art

Looks like it's all fixed up in the latest CVS. Thanks!!

--Art


Upcoming Events

No records to display

Why Register?

Register at tiki.org and you'll be able to use the account at any *.tiki.org site, thanks to the InterTiki feature. A valid email address is required to receive site notifications and occasional newsletters. You can opt out of these items at any time.